Reset password email not triggered

Hey @alexgeorg, while tried to rest the password using the reset link, mail not triggered, also I have cross checked the email configuration and its correct.

export MAILER_USER=’’ () (**)
export MAILER_PASSWORD=’’ (
) ()
export MAILER_SENDER=’’ (*) (
)
export MAILER_HOSTNAME=’’ (*) (**)

Please guide us.

Hello @mohan,
In order password reset to be functional valid configuration is needed for the mailer module. Have your created an account on https://www.mailgun.com/ or something similar?

Hey @alexgeorg,
Thanks.
I created an account on https://www.mailgun.com/ and then set it to developement.env as,
export MAILER_USER=’’ -> gave the mail id created on mailgun
export MAILER_PASSWORD=’’ -> gave password of the mailgun id
export MAILER_HOSTNAME = ‘smtp.mailgun.org
and then restarted and tried to reset password. I received the following error in terminal,

"error: Cannot set property ‘passwordResetToken’ of undefined message=Cannot set property ‘passwordResetToken’ of undefined, locations=[line=2, column=3], path=[sendPasswordResetEmail], code=INTERNAL_SERVER_ERROR, stacktrace=[TypeError: Cannot set property ‘passwordResetToken’ of undefined, at sendPasswordResetEmail (/root/editoria 2nd instance/editoria-vanilla/node_modules/@pubsweet/component-password-reset-server/src/resolvers.js:26:31)]
info: ::1 - - [03/Dec/2020:04:54:46 +0000] “POST /graphql HTTP/1.1” 200 188 “http://localhost:3040/password-reset” “Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Safari/537.36”

info: Saved EditoriaUser with UUID 1e5ec976-8d4f-4fbc-8302-f48ea3796dee
info: Sending password reset email to itechy43@gmail.com
error: Failed to send email Error: getaddrinfo ENOTFOUND smtp_server_placeholder
info: ::1 - - [03/Dec/2020:04:54:55 +0000] “POST /graphql HTTP/1.1” 200 41 “http://localhost:3040/password-reset” “Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Safari/537.36"”

Have I missed something in configuration or is there any other solution to fix this?
Please help me out of it.

thanks for the feedback @ShibinaS I will look into it

@ShibinaS this is a bug. You can follow this gitlab issue for updates on when this will be resolved (expected next week)

Thanks for the update, @Dione.